Cloudflare Outage Affecting Builds

Incident Report for Galaxy

Resolved

This incident has been resolved.
Posted Jun 13, 2025 - 06:01 EDT

Update

We are continuing to monitor for any further issues.
Posted Jun 12, 2025 - 18:20 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 12, 2025 - 18:10 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 12, 2025 - 18:00 EDT

Investigating

We are currently experiencing issues due to a Cloudflare outage.

The following URLs used in our infrastructure are impacted:

https://warehouse.meteor.com
https://static.meteor.com

During builds, you may encounter messages like:
Problem downloading Meteor binaries or issues when downloading Atmosphere packages.

As a result, your build may fail intermittently or take longer than usual to complete.

This is due to Cloudflare instability affecting the delivery of these resources. We are actively monitoring the situation and will provide updates as necessary.
Posted Jun 12, 2025 - 16:06 EDT
This incident affected: Meteor package server and Atmosphere.