Intermittent performance on PushToDeploy

Incident Report for Galaxy

Resolved

This incident has been resolved.
Posted Oct 15, 2025 - 08:29 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 15, 2025 - 08:28 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Oct 14, 2025 - 13:36 EDT

Investigating

We are observing periods of slowness on PushToDeploy due to machine replacements and reallocation in our execution cluster. During these windows, build and deploy queues may grow and complete more slowly than usual. We are monitoring and adjusting capacity to stabilize the service.
Posted Oct 14, 2025 - 13:36 EDT
This incident affected: P2D - Push To Deploy.