We've successfully deployed a fix for the Push to Deploy integration issue. Customers can now deploy applications using Push to Deploy for both WebApps and Meteor apps. We're actively monitoring the situation to ensure stability. Thanks for your patience while we worked through this.
Posted Jan 07, 2026 - 12:48 EST
Update
We've successfully stabilized Push to Deploy for Web Apps (non-Meteor) applications. We're now prioritizing the resolution for Meteor apps and will have an update soon. If you're using a Meteor app, you can continue using the Meteor CLI to deploy. Check out our CLI documentation for deployment instructions. https://help.galaxycloud.app/en/article/deploy-a-new-meteor-app-using-the-cli-1vzo6do/
Posted Jan 07, 2026 - 09:40 EST
Identified
We've identified the root cause and are actively working on a fix. Our team is prioritizing this and will have an update soon. As a workaround, if you're using a Meteor app, you can use the Meteor CLI to deploy in the meantime. Check out our CLI documentation for deployment instructions while we work on restoring Push to Deploy functionality: https://help.galaxycloud.app/en/article/deploy-a-new-meteor-app-using-the-cli-1vzo6do/
Posted Jan 07, 2026 - 07:25 EST
Investigating
Some customers are experiencing issues with Push to Deploy. Affected customers are unable to trigger new application deployments automatically via commits, or have lost their GitHub connection entirely within Push to Deploy settings on Galaxy. Our team is investigating the root cause and working on a resolution.