Galaxy Cloud Dashboard Instability

Incident Report for Galaxy

Resolved

This incident has been resolved.
Posted May 09, 2025 - 20:15 EDT

Update

We are continuing to monitor for any further issues.
Posted May 09, 2025 - 19:58 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 09, 2025 - 19:58 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted May 09, 2025 - 19:57 EDT

Investigating

We are currently experiencing instability with the Galaxy Cloud dashboard at beta.galaxycloud.app, which may prevent users from accessing or managing their applications.

While we work to resolve the issue, you can continue managing your apps using the legacy regional UI:

🌎 Americas: https://galaxy.meteor.com/

🌏 Asia: https://ap-southeast-2.galaxy.meteor.com/

🌍 Europe: https://eu-west-1.galaxy.meteor.com/

We appreciate your patience and are working to restore full access as soon as possible.
Posted May 09, 2025 - 19:19 EDT
This incident affected: Galaxy management interface.