Galaxy Cloud Dashboard Instability

Incident Report for Galaxy

Resolved

We experienced a period of instability with the Galaxy Cloud dashboard at beta.galaxycloud.app, which may have prevented users from accessing or managing their applications.

Our engineering team identified and resolved the issue quickly. Full functionality has been restored, and we are continuing to monitor the system to ensure continued stability.
Posted May 15, 2025 - 10:20 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 15, 2025 - 10:17 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted May 15, 2025 - 10:15 EDT

Investigating

We are currently investigating this issue.
Posted May 15, 2025 - 10:10 EDT
This incident affected: Galaxy management interface.