Some Users Redirected to "Not Found" Page on Galaxy Beta Dashboard

Incident Report for Galaxy

Identified

The issue has been identified and a fix is being implemented.
Posted Oct 09, 2025 - 16:01 EDT

Investigating

We are currently investigating an issue where some users are being redirected to an invalid "Not Found" page (https://beta.galaxycloud.app/undefined/us-east-1) when attempting to access the Galaxy Beta Dashboard.

Our team is actively working to identify the root cause and restore normal access as quickly as possible.

We appreciate your patience and will provide updates as soon as we have more information.
Posted Oct 09, 2025 - 08:57 EDT
This incident affects: Galaxy management interface and Galaxy Beta.