Meteor App Deployments Affected on Push to Deploy

Incident Report for Galaxy

Resolved

This incident has been resolved.
Posted Jan 19, 2026 - 15:43 EST

Update

A fix has been implemented for the Push to Deploy issue affecting Meteor apps, including the settings persistence after commits. We're actively monitoring the situation to ensure stability. Thanks for your patience while we worked through this.
Posted Jan 19, 2026 - 11:09 EST

Monitoring

We've restored Push to Deploy functionality for new Meteor app deployments. Users can now deploy new and existing Meteor apps using Push to Deploy in the Galaxy Dashboard.

However, some customers may experience an issue where Push to Deploy settings are lost after a commit. If this happens, you'll need to reconfigure your Push to Deploy settings manually in the Galaxy Dashboard.
Posted Jan 17, 2026 - 14:23 EST

Investigating

We are currently investigating an issue affecting Push to Deploy for Meteor applications. Users are unable to deploy new or existing Meteor apps using Push to Deploy in the Galaxy Dashboard.

As a workaround, you can deploy your Meteor app using the CLI. Check out our documentation for deployment instructions:
https://help.galaxycloud.app/en/article/deploy-a-new-meteor-app-using-the-cli-1vzo6do/

Our team is actively investigating the root cause and will provide updates as we have more information. We appreciate your patience.
Posted Jan 16, 2026 - 16:52 EST
This incident affected: P2D - Push To Deploy.