Instability in P2D – Galaxy US Infrastructure

Incident Report for Galaxy

Resolved

This incident has been resolved.
Posted Oct 22, 2025 - 08:53 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 20, 2025 - 06:54 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Oct 20, 2025 - 05:47 EDT

Investigating

We are currently experiencing issues with the P2D service in the Galaxy US infrastructure. Initial findings indicate a failure in AWS services that is impacting our systems.

AWS has acknowledged problems on their platform:
https://health.aws.amazon.com/health/status
Posted Oct 20, 2025 - 04:47 EDT
This incident affected: P2D - Push To Deploy and Galaxy US infrastructure.